<?xml version="1.0" encoding="utf-8"?>
<rdf:RDF
   xmlns:bibo="http://purl.org/ontology/bibo/"
   xmlns:dc="http://purl.org/dc/elements/1.1/"
   xmlns:dcterms="http://purl.org/dc/terms/"
   xmlns:foaf="http://xmlns.com/foaf/0.1/"
   xmlns:owl="http://www.w3.org/2002/07/owl#"
   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
   xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
   xmlns:schema="https://schema.org/"
   xmlns:vann="http://purl.org/vocab/vann/"
   xmlns:vs="http://www.w3.org/2003/06/sw-vocab-status/ns#"
>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#Ontology"/>
    <rdfs:label xml:lang="en">Five Stars of Online Research Articles Ontology (FiveStars)</rdfs:label>
    <dc:creator rdf:datatype="http://www.w3.org/2001/XMLSchema#string">David Shotton (https://orcid.org/0000-0001-5506-523X)</dc:creator>
    <dc:contributor rdf:datatype="http://www.w3.org/2001/XMLSchema#string">Sebastian Barzaghi (https://orcid.org/0000-0002-0799-1527)</dc:contributor>
    <dc:date>2026-08-14</dc:date>
    <dc:description xml:lang="en">
The **_Five Stars of Online Research Articles Ontology (FiveStars)_** is an ontology written in OWL 2 DL to enable characterization of the five attributes of an online journal article - peer review, open access, enriched content, available datasets and machine-readable metadata - using the criteria discussed in the paper by David Shotton entitled [The Five Stars of Online Journal Articles — a Framework for Article Evaluation](https://doi.org/10.1045/january2012-shotton).

The five attributes are:
* **Peer review.** Ensure your article is peer reviewed, to provide assurance of its scholarly value, quality and integrity. Possible values: (0) no peer review, (1) pre-publication peer review, (2) responsive peer review, (3) post-publication peer review, (4) open peer review.
* **Open access.** Ensure others have cost-free open access both to read and to reuse your published article, to ensure its greatest possible readership and usefulness. Possible values: (0) no open access, (1) self-archiving green/gratis open access, (2) funder-mandated green/gratis open access, (3) author-pays gold/gratis open access, (4) author-pays gold/libre open access.
* **Enriched content.** Use the full potential of Web technologies and Web standards to provide interactivity and semantic enrichment to the content of your online article. Possible values: (0) no enhancements, (1) active Web links, (2) semantic enrichment of the text, (3) 'lively' content, (4) data fusions ("mash-ups").
* **Available datasets.** Ensure that all the data supporting the results you report are published under an open license, with sufficient metadata to enable their re-interpretation and reuse. Possible values: (0) no published data, (1) supplementary information files available, (2) article data downloadable in actionable form, (3) underlying datasets published, (4) data available to peer-reviewers.
* **Machine-readable metadata.** Publish machine-readable metadata describing both your article and your cited references, so that these descriptions can be discovered and reused automatically. Possible values: (0) no available metadata, (1) structural markup available, (2) bibliographic and citation metadata available, (3) rich embedded markup, (4) structured article summary.

![The properties introduced in FiveStars.](fivestars.png)

The ontology is simple, consisting only of those data properties (e.g., `fivestars:hasOpenAccessRating` and `fivestars:openAccessRatingComment`) required to permit a rating for each of the five stars, and for the paper as a whole, to be recorded as an integer, together with an associated comment. 
It is intended for use by publishers and others wishing to encode Five Stars ratings for individual papers in machine-readable form.

Other ontologies, for example [DCMI Metadata Terms](http://dublincore.org/documents/dcmi-terms/) and the [FRBR-aligned Bibliographic Ontology (FaBiO)](http://purl.org/spar/fabio), may be used to describe other aspects of a journal article, e.g. authors, journal name, and publication year.

## Examples of use

In the following subsections, we introduce some examples to showcase how to use FiveStars. 

The prefixes that are used in all the examples provided below are defined as follows:

    @prefix fivestars: &lt;http://purl.org/spar/fivestars/&gt; .
    @prefix xsd: &lt;http://www.w3.org/2001/XMLSchema#&gt; .

### Rating an article with the Five Stars of Online Journal Articles

The Five Stars of Online Journal Articles Ontology allows to encode ratings machine-readable form according to five different criteria, i.e., peer review, open access, enhanced content, available datasets, and machine-readable metadata. 

    &lt;http://doi.org/10.1045/january2012-shotton&gt;
        fivestars:hasPeerReviewRating
            "3"^^xsd:nonNegativeInteger ;
        fivestars:peerReviewRatingComment
            "Post-publication responsive peer review of the preprint." ;

        fivestars:hasOpenAccessRating
            "4"^^xsd:nonNegativeInteger ;
        fivestars:openAccessRatingComment
            "Gold/libre open access without author fee!" ;

        fivestars:hasEnhancedContentRating
            "1"^^xsd:nonNegativeInteger ;
        fivestars:enhancedContentRatingComment
            "Plentiful Web links in text and to all references. No
            additional semantic enhancement of text." ;

        fivestars:hasAvailableDatasetsRating
            "0"^^xsd:nonNegativeInteger ;

        fivestars:hasMachine-readableMetadataRating
            "1"^^xsd:nonNegativeInteger ;
        fivestars:machine-readableMetadataRatingComment
            "Structural markup in HTML only." ;

        fivestars:hasOverallFiveStarsRating
            "9"^^xsd:nonNegativeInteger ;
        fivestars:overallFiveStarsRatingComment
            "The nature of this article, being a position paper rather
            than a research paper with primary research data, has
            influenced the overall rating obtained." .

## Competency Questions

FiveStars can be used for answering several questions related to the main characteristics of online journal articles.
In the following subsections, some of them are introduced together with their respective SPARQL queries. 

The prefixes that are used in all the SPARQL queries provided below are defined as follows:

    PREFIX fivestars: &lt;http://purl.org/spar/fivestars/&gt;

### CQ1

What is the overall five-star rating and associated evaluation comment for a given resource?

    SELECT ?resource ?overallRating ?comment
    WHERE {
        ?resource fivestars:hasOverallFiveStarsRating ?overallRating .
        OPTIONAL { ?resource fivestars:overallFiveStarsRatingComment ?comment . }
    }

### CQ2

What is the peer review rating and its explanatory comment for a resource?

    SELECT ?resource ?peerReviewRating ?comment
    WHERE {
        ?resource fivestars:hasPeerReviewRating ?peerReviewRating .
        OPTIONAL { ?resource fivestars:peerReviewRatingComment ?comment . }
    }

### CQ3

What is the open access rating and its justification for a resource?

    SELECT ?resource ?openAccessRating ?comment
    WHERE {
        ?resource fivestars:hasOpenAccessRating ?openAccessRating .
        OPTIONAL { ?resource fivestars:openAccessRatingComment ?comment . }
    }

### CQ4

What are the content enhancement and dataset availability ratings for a resource?

    SELECT ?resource ?enhancedContentRating ?enhancedContentComment ?datasetsRating
    WHERE {
        ?resource fivestars:hasEnhancedContentRating ?enhancedContentRating ;
            fivestars:hasAvailableDatasetsRating ?datasetsRating .
        OPTIONAL { ?resource fivestars:enhancedContentRatingComment ?enhancedContentComment . }
    }

### CQ5

What is the complete five-star dimensional breakdown (peer review, open access, enhanced content, available datasets, and machine-readable metadata) for a resource?

    SELECT ?resource ?peerReview ?openAccess ?enhancedContent ?datasets ?metadata ?overall
    WHERE {
    ?resource fivestars:hasPeerReviewRating ?peerReview ;
        fivestars:hasOpenAccessRating ?openAccess ;
        fivestars:hasEnhancedContentRating ?enhancedContent ;
        fivestars:hasAvailableDatasetsRating ?datasets ;
        fivestars:hasMachine-readableMetadataRating ?metadata ;
        fivestars:hasOverallFiveStarsRating ?overall .
    }

</dc:description>
    <dc:title xml:lang="en">The Five Stars of Online Research Articles Ontology (FiveStars)</dc:title>
    <owl:backwardCompatibleWith rdf:resource="http://purl.org/spar/fivestars/2012-01-16"/>
    <owl:priorVersion rdf:resource="http://purl.org/spar/fivestars/2012-01-16"/>
    <owl:versionIRI rdf:resource="http://purl.org/spar/fivestars/2026-08-14"/>
    <dcterms:bibliographicCitation>Shotton, D. (2012). The Five Stars of Online Journal Articles - a Framework for Article Evaluation. In D-Lib Magazine, 18 (1/2). https://doi.org/10.1045/january2012-shotton (Open Access)</dcterms:bibliographicCitation>
    <dcterms:created>2012-01-16</dcterms:created>
    <dcterms:issued>2012-01-16</dcterms:issued>
    <dcterms:modified>2026-08-14</dcterms:modified>
    <bibo:doi>https://doi.org/10.25504/FAIRsharing.6dfe9b</bibo:doi>
    <vann:preferredNamespacePrefix xml:lang="en">fivestars</vann:preferredNamespacePrefix>
    <vann:preferredNamespaceUri xml:lang="en">http://purl.org/spar/fivestars</vann:preferredNamespaceUri>
    <rdfs:seeAlso rdf:resource="http://www.sparontologies.net/ontologies/fivestars"/>
    <dcterms:license rdf:resource="http://creativecommons.org/licenses/by/4.0/"/>
    <dcterms:publisher rdf:resource="https://ror.org/00wb4mk85"/>
    <dcterms:source rdf:resource="https://github.com/SPAROntologies/fivestars/blob/master/docs/cq.md"/>
    <foaf:logo rdf:resource="https://github.com/SPAROntologies/fivestars/blob/master/spar.png"/>
    <schema:codeRepository rdf:resource="https://github.com/SPAROntologies/fivestars"/>
    <schema:includedInDataCatalog rdf:resource="https://fairsharing.org/"/>
    <bibo:status rdf:resource="http://purl.org/ontology/bibo/status/published"/>
    <owl:versionInfo rdf:datatype="http://www.w3.org/2001/XMLSchema#string">1.1.0</owl:versionInfo>
    <schema:keywords xml:lang="en">semantic publishing</schema:keywords>
    <schema:keywords xml:lang="en">scholarly publishing</schema:keywords>
    <schema:keywords xml:lang="en">scholarly ratings</schema:keywords>
    <schema:keywords xml:lang="en">scientometrics</schema:keywords>
    <schema:keywords xml:lang="en">bibliometrics</schema:keywords>
    <schema:image rdf:resource="https://github.com/SPAROntologies/fivestars/blob/master/docs/current/fivestars.png"/>
    <vann:changes xml:lang="en">
* **v1.1.0**: added new documentation, including annotation properties (e.g., `bibo:doi`, `schema:codeRepository`, etc.), term properties (e.g., `vann:example`, `vs:term_status`, etc.), exemplary competency questions with their respective SPARQL queries, and a Grafoo diagram.
    </vann:changes>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasMachine-readableMetadataRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has machine-readable metadata rating</rdfs:label>
    <rdfs:comment xml:lang="en">Integer rating (from 0 to 4) given to journal artice for machine-readable metadata.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasMachine-readableMetadataRating "1"^^xsd:nonNegativeInteger ;
        fivestars:machine-readableMetadataRatingComment "Structural markup has been provided." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasOpenAccessRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has open access rating</rdfs:label>
    <rdfs:comment xml:lang="en">Integer rating (from 0 to 4) given to journal artice for open access.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasOpenAccessRating "4"^^xsd:nonNegativeInteger ;
        fivestars:openAccessRatingComment "The article has been published in gold open access." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/openAccessRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">open access rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment explaining Five Stars ratings given to journal artice relating to open access.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasOpenAccessRating "4"^^xsd:nonNegativeInteger ;
        fivestars:openAccessRatingComment "The article has been published in gold open access." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasEnhancedContentRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has enhanced content rating</rdfs:label>
    <rdfs:comment xml:lang="en">Integer rating (from 0 to 4) given to journal artice for enhanced content.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasEnhancedContentRating "1"^^xsd:nonNegativeInteger ;
        fivestars:enhancedContentRatingComment "Active web links have been provided." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/enhancedContentRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">enhanced content rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment explaining Five Stars ratings given to journal artice relating to enhanced content.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasEnhancedContentRating "1"^^xsd:nonNegativeInteger ;
        fivestars:enhancedContentRatingComment "Active web links have been provided." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/title">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasPeerReviewRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has peer review rating</rdfs:label>
    <rdfs:comment xml:lang="en">Integer rating (from 0 to 4) given to journal artice for peer review.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasPeerReviewRating "3"^^xsd:nonNegativeInteger ;
        fivestars:peerReviewRatingComment "Post-publication peer review is available." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/availableDatasetsRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">available datasets rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment explaining Five Stars ratings given to journal artice relating to available datasets.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasAvailableDatasetsRating "0"^^xsd:nonNegativeInteger ;
        fivestars:availableDatasetsRatingComment "No data has been published." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/peerReviewRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">peer review rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment explaining Five Stars ratings given to journal artice relating to peer review.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasPeerReviewRating "3"^^xsd:nonNegativeInteger ;
        fivestars:peerReviewRatingComment "Post-publication peer review is available." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/date">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/machine-readableMetadataRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">machine-readable metadata rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment explaining Five Stars ratings given to journal artice relating to machine-readable metadata.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasMachine-readableMetadataRating "1"^^xsd:nonNegativeInteger ;
        fivestars:machine-readableMetadataRatingComment "Structural markup has been provided." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/overallFiveStarsRatingComment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">overall five stars rating comment</rdfs:label>
    <rdfs:comment xml:lang="en">A comment on overall Five Stars rating given to journal artice.</rdfs:comment>
    <vann:example>
    :my-article
        fivestars:hasOverallFiveStarsRating "9"^^xsd:nonNegativeInteger ;
        fivestars:overallFiveStarsRatingComment 
            "The nature of this article, being a position paper rather
            than a research paper with primary research data, has
            influenced the overall rating obtained." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://www.w3.org/2002/07/owl#versionInfo">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasOverallFiveStarsRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has overall five stars rating</rdfs:label>
    <rdfs:comment xml:lang="en">Overall Five stars rating (on integer scale from from 0 to 20) given to journal artice, obtained by summing the individual ratings given for each of the Five Stars of Online Journal Articles.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasOverallFiveStarsRating "9"^^xsd:nonNegativeInteger ;
        fivestars:overallFiveStarsRatingComment 
            "The nature of this article, being a position paper rather
            than a research paper with primary research data, has
            influenced the overall rating obtained." .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://www.w3.org/2002/07/owl#priorVersion">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/contributor">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/spar/fivestars/hasAvailableDatasetsRating">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#DatatypeProperty"/>
    <rdfs:label xml:lang="en">has available datasets rating</rdfs:label>
    <rdfs:comment xml:lang="en">Integer rating (from 0 to 4) given to journal artice for available datasets.</rdfs:comment>
    <rdfs:range rdf:resource="http://www.w3.org/2001/XMLSchema#nonNegativeInteger"/>
    <vann:example>
    :my-article
        fivestars:hasAvailableDatasetsRating "0"^^xsd:nonNegativeInteger ;
        fivestars:availableDatasetsRatingComment "No data has been published" .
    </vann:example>
    <rdfs:isDefinedBy rdf:resource="http://purl.org/spar/fivestars/"/>
    <vs:term_status rdf:resource="http://purl.org/linked-data/registry#statusStable"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/description">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://www.w3.org/2000/01/rdf-schema#comment">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/rights">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://purl.org/dc/elements/1.1/creator">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://www.w3.org/2000/01/rdf-schema#label">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#AnnotationProperty"/>
  </rdf:Description>
  <rdf:Description rdf:about="http://www.w3.org/2002/07/owl#topObjectProperty">
    <rdf:type rdf:resource="http://www.w3.org/2002/07/owl#ObjectProperty"/>
  </rdf:Description>
</rdf:RDF>
