The **_Five Stars of Online Research Articles Ontology (FiveStars)_** is an ontology written in OWL 2 DL to enable characterization of the five attributes of an online journal article - peer review, open access, enriched content, available datasets and machine-readable metadata - using the criteria discussed in the paper by David Shotton entitled [The Five Stars of Online Journal Articles — a Framework for Article Evaluation](https://doi.org/10.1045/january2012-shotton).
The five attributes are:
* **Peer review.** Ensure your article is peer reviewed, to provide assurance of its scholarly value, quality and integrity. Possible values: (0) no peer review, (1) pre-publication peer review, (2) responsive peer review, (3) post-publication peer review, (4) open peer review.
* **Open access.** Ensure others have cost-free open access both to read and to reuse your published article, to ensure its greatest possible readership and usefulness. Possible values: (0) no open access, (1) self-archiving green/gratis open access, (2) funder-mandated green/gratis open access, (3) author-pays gold/gratis open access, (4) author-pays gold/libre open access.
* **Enriched content.** Use the full potential of Web technologies and Web standards to provide interactivity and semantic enrichment to the content of your online article. Possible values: (0) no enhancements, (1) active Web links, (2) semantic enrichment of the text, (3) 'lively' content, (4) data fusions ("mash-ups").
* **Available datasets.** Ensure that all the data supporting the results you report are published under an open license, with sufficient metadata to enable their re-interpretation and reuse. Possible values: (0) no published data, (1) supplementary information files available, (2) article data downloadable in actionable form, (3) underlying datasets published, (4) data available to peer-reviewers.
* **Machine-readable metadata.** Publish machine-readable metadata describing both your article and your cited references, so that these descriptions can be discovered and reused automatically. Possible values: (0) no available metadata, (1) structural markup available, (2) bibliographic and citation metadata available, (3) rich embedded markup, (4) structured article summary.

The ontology is simple, consisting only of those data properties (e.g., `fivestars:hasOpenAccessRating` and `fivestars:openAccessRatingComment`) required to permit a rating for each of the five stars, and for the paper as a whole, to be recorded as an integer, together with an associated comment.
It is intended for use by publishers and others wishing to encode Five Stars ratings for individual papers in machine-readable form.
Other ontologies, for example [DCMI Metadata Terms](http://dublincore.org/documents/dcmi-terms/) and the [FRBR-aligned Bibliographic Ontology (FaBiO)](http://purl.org/spar/fabio), may be used to describe other aspects of a journal article, e.g. authors, journal name, and publication year.
## Examples of use
In the following subsections, we introduce some examples to showcase how to use FiveStars.
The prefixes that are used in all the examples provided below are defined as follows:
@prefix fivestars: <http://purl.org/spar/fivestars/> .
@prefix xsd: <http://www.w3.org/2001/XMLSchema#> .
### Rating an article with the Five Stars of Online Journal Articles
The Five Stars of Online Journal Articles Ontology allows to encode ratings machine-readable form according to five different criteria, i.e., peer review, open access, enhanced content, available datasets, and machine-readable metadata.
<http://doi.org/10.1045/january2012-shotton>
fivestars:hasPeerReviewRating
"3"^^xsd:nonNegativeInteger ;
fivestars:peerReviewRatingComment
"Post-publication responsive peer review of the preprint." ;
fivestars:hasOpenAccessRating
"4"^^xsd:nonNegativeInteger ;
fivestars:openAccessRatingComment
"Gold/libre open access without author fee!" ;
fivestars:hasEnhancedContentRating
"1"^^xsd:nonNegativeInteger ;
fivestars:enhancedContentRatingComment
"Plentiful Web links in text and to all references. No
additional semantic enhancement of text." ;
fivestars:hasAvailableDatasetsRating
"0"^^xsd:nonNegativeInteger ;
fivestars:hasMachine-readableMetadataRating
"1"^^xsd:nonNegativeInteger ;
fivestars:machine-readableMetadataRatingComment
"Structural markup in HTML only." ;
fivestars:hasOverallFiveStarsRating
"9"^^xsd:nonNegativeInteger ;
fivestars:overallFiveStarsRatingComment
"The nature of this article, being a position paper rather
than a research paper with primary research data, has
influenced the overall rating obtained." .
## Competency Questions
FiveStars can be used for answering several questions related to the main characteristics of online journal articles.
In the following subsections, some of them are introduced together with their respective SPARQL queries.
The prefixes that are used in all the SPARQL queries provided below are defined as follows:
PREFIX fivestars: <http://purl.org/spar/fivestars/>
### CQ1
What is the overall five-star rating and associated evaluation comment for a given resource?
SELECT ?resource ?overallRating ?comment
WHERE {
?resource fivestars:hasOverallFiveStarsRating ?overallRating .
OPTIONAL { ?resource fivestars:overallFiveStarsRatingComment ?comment . }
}
### CQ2
What is the peer review rating and its explanatory comment for a resource?
SELECT ?resource ?peerReviewRating ?comment
WHERE {
?resource fivestars:hasPeerReviewRating ?peerReviewRating .
OPTIONAL { ?resource fivestars:peerReviewRatingComment ?comment . }
}
### CQ3
What is the open access rating and its justification for a resource?
SELECT ?resource ?openAccessRating ?comment
WHERE {
?resource fivestars:hasOpenAccessRating ?openAccessRating .
OPTIONAL { ?resource fivestars:openAccessRatingComment ?comment . }
}
### CQ4
What are the content enhancement and dataset availability ratings for a resource?
SELECT ?resource ?enhancedContentRating ?enhancedContentComment ?datasetsRating
WHERE {
?resource fivestars:hasEnhancedContentRating ?enhancedContentRating ;
fivestars:hasAvailableDatasetsRating ?datasetsRating .
OPTIONAL { ?resource fivestars:enhancedContentRatingComment ?enhancedContentComment . }
}
### CQ5
What is the complete five-star dimensional breakdown (peer review, open access, enhanced content, available datasets, and machine-readable metadata) for a resource?
SELECT ?resource ?peerReview ?openAccess ?enhancedContent ?datasets ?metadata ?overall
WHERE {
?resource fivestars:hasPeerReviewRating ?peerReview ;
fivestars:hasOpenAccessRating ?openAccess ;
fivestars:hasEnhancedContentRating ?enhancedContent ;
fivestars:hasAvailableDatasetsRating ?datasets ;
fivestars:hasMachine-readableMetadataRating ?metadata ;
fivestars:hasOverallFiveStarsRating ?overall .
}