The **_Funding, Research Administration and Projects Ontology (FRAPO)_** is a [CERIF-compliant](http://www.eurocris.org/cerif/main-features-cerif) ontology for describing administrative information relating to grant funding and research projects.
It can be used for the characterization of grant applications (e.g., `frapo:Grant`), funding bodies (e.g., `frapo:University`), research projects, project partners, etc.; in other words, the sort of information stored in Current Research Information Systems (CRIS).
It can also be used to describe other types of projects, for example building projects and educational projects.
FRAPO, which is written in OWL 2 DL, imports [FOAF](http://xmlns.com/foaf/spec/) for characterizing people.
FRAPO is designed to be used in conjunction with [SCoRO](https://www.sparontologies.net/ontologies/scoro) that provides structured vocabulary terms to describe the contributions (`scoro:Contribution`) and roles of scholars (`pro:Role`), and the organizations of which they are members, with respect to projects, research investigations and other academic activities describable using FRAPO, and to the scholarly journal articles and other outputs that result from them.

Terms for documents of relevance to the scholarly domain covered by FRAPO, including grant applications, project plans, project reports, datasets and journal articles, are already provided by [FaBiO](https://www.sparontologies.net/ontologies/fabio) and are therefore not included within FRAPO.
FRAPO also permits descriptions of various types of applications, funding programs, infrastructure entities (e.g., services and research facilities), and a wide range of financial entities (e.g., accounts, contracts, quotations, purchases, invoices and payments), and the relationships between them (e.g., has application outcome, is manufactured by, is purchased by, has dispatch date, has purchase order number, has acronym) not shown in the diagram above.
## Examples of use
In the following subsections, we introduce some examples to showcase how to use FRAPO.
The prefixes that are used in all the examples provided below are defined as follows:
@prefix : <http://www.sparontologies.net/example/> .
@prefix fabio: <http://purl.org/spar/fabio/> .
@prefix foaf: <http://xmlns.com/foaf/0.1/> .
@prefix frapo: <http://purl.org/cerif/frapo/> .
@prefix person: <http://data.semanticweb.org/person/> .
@prefix org: <http://data.semanticweb.org/organization/> .
@prefix pro: <http://purl.org/spar/pro/> .
@prefix scoro: <http://purl.org/spar/scoro/> .
### Describing fundings, investigations and research outputs
The specification of the connection between a research paper, the investigation done and discussed in it and the funds that allowed such investigation are important aspects to describe in the paper itself. Usually, such aspects are introduced in a footnote or, even better, in an appropriate acknowledgement section that describe them in natural language.
The use of FRAPO in combination with other SPAR Ontologies such as FaBiO and SCoRO permits the description of the aforementioned aspects in RDF. For instance, the well-known paper published by a young Peter Mika and entitled "Ontologies are us: a unified model of social networks and semantics" has been one of the outcomes of Mika's investigation founded by his Ph.D. scholarship.
FRAPO allows one to explicitly describe all of this by means of its several classes and properties.
org:vrije-universiteit-amsterdam a frapo:University ;
foaf:name "Free University Amsterdam"@en ;
frapo:awards :phd-scholarship-2004 .
:investigation a frapo:Investigation ;
frapo:hasOutput
<http://dx.doi.org/10.1016/j.websem.2006.11.002> .
:phd-scholarship-2004 a frapo:Scholarship ;
foaf:name "Ph.D. Scholarship 2004" ;
frapo:funds :investigation .
person:peter-mika a foaf:Person ;
foaf:name "Peter Mika" ;
pro:holdsRoleInTime :affiliation-vua ;
scoro:makesContribution
:mika-writes-draft ,
:mika-revises-manuscript .
:mika-writes-draft a scoro:ContributionSituation ;
scoro:withContribution scoro:writes-manuscript-draft ;
scoro:withContributionEffort scoro:solo-effort ;
scoro:relatesToEntity
<http://dx.doi.org/10.1016/j.websem.2006.11.002> .
:mika-revises-manuscript a scoro:ContributionSituation ;
scoro:withContribution scoro:revises-manuscript ;
scoro:withContributionEffort scoro:solo-effort ;
scoro:relatesToEntity
<http://dx.doi.org/10.1016/j.websem.2006.11.002> .
:affiliation-vua a pro:RoleInTime ;
pro:withRole scoro:affiliate ;
pro:relatesToOrganization org:vrije-universiteit-amsterdam ;
pro:relatesToDocument
<http://dx.doi.org/10.1016/j.websem.2006.11.002> .
## Competency Questions
FRAPO can be used for answering several questions related to administrative information about grant funding and research projects.
In the following subsections, some of them are introduced together with their respective SPARQL queries.
The prefixes that are used in all the SPARQL queries provided below are defined as follows:
PREFIX frapo: <http://purl.org/cerif/frapo/>
PREFIX scoro: <http://purl.org/spar/scoro/>
PREFIX foaf: <http://xmlns.com/foaf/0.1/>
PREFIX pro: <http://purl.org/spar/pro/>
### CQ1
Which funding awards or scholarships are granted by a university?
SELECT ?university ?universityName ?award ?awardName
WHERE {
?university a frapo:University ;
frapo:awards ?award .
OPTIONAL { ?university foaf:name ?universityName . }
OPTIONAL { ?award foaf:name ?awardName . }
}
### CQ2
Which investigation is funded by a specific scholarship?
SELECT ?fundingAward ?awardName ?investigation
WHERE {
?fundingAward a frapo:Scholarship ;
frapo:funds ?investigation .
?investigation a frapo:Investigation .
OPTIONAL { ?fundingAward foaf:name ?awardName . }
}
### CQ3
What outputs are produced by an investigation?
SELECT ?investigation ?outputDocument
WHERE {
?investigation a frapo:Investigation ;
frapo:hasOutput ?outputDocument .
}
### CQ4
Which funding awards granted by a university finance an investigation that produced a document to which an author is affiliated?
SELECT ?person ?university ?award ?investigation ?document
WHERE {
?person a foaf:Person ;
pro:holdsRoleInTime ?roleInTime .
?roleInTime pro:relatesToOrganization ?university ;
pro:relatesToDocument ?document .
?university a frapo:University ;
frapo:awards ?award .
?award frapo:funds ?investigation .
?investigation frapo:hasOutput ?document .
}
### CQ5
What specific contributions are made by a person toward an output document resulting from a funded investigation?
SELECT ?person ?contributionType ?effort ?document ?investigation
WHERE {
?person a foaf:Person ;
scoro:makesContribution ?situation .
?situation a scoro:ContributionSituation ;
scoro:withContribution ?contributionType ;
scoro:relatesToEntity ?document .
?investigation a frapo:Investigation ;
frapo:hasOutput ?document .
OPTIONAL { ?situation scoro:withContributionEffort ?effort . }
}