The **_Mention Typing Ontology (MiTO)_** is an OWL 2 DL ontology designed to formalize the concept of mentions, which are crucial for bibliometric analysis, as they allow researchers to track references to entities (e.g., software) in scholarly communication.
MiTO introduces the following key concepts:
* **Mention**, which represents the act of referring to or introducing the name of a person, entity, or concept in discourse.
This class is defined with minimal restrictions to maximize usability across different contexts.
* **MentionType**, which reifies the implicit or explicit nature of a mention, enabling users to classify mentions based on their characteristics.
Mentions can be explicit (e.g., directly stated references in text, as when stated into an article _Dr. Johnson's groundbreaking research on climate change_) or implicit (e.g., indirect references to entities or concepts, such as discussing "seminal studies in the field").
MiTO also defines several object properties to describe relationships between mentions and entities:
* `mito:mentions` and its inverse `mito:isMentionedBy`, which connect the two sides involved in the act of mentioning.
* `mito:hasMentionedEntity`, which relates a mention to the entity being mentioned.
* `mito:hasMentioningEntity`, which relates a mention to the entity performing the act of mentioning.
* `mito:hasMentionType`, which defines the implicit or explicit character of the mention.

MiTO is designed to integrate with other SPAR ontologies, which provides a modular framework for describing crucial aspects of bibliographic entities and their metadata.
## Examples of use
In the following subsections, we introduce some examples to showcase how to use MiTO.
The prefixes that are used in all the examples provided below are defined as follows:
@prefix : <http://www.sparontologies.net/example/> .
@prefix mito: <http://purl.org/spar/mito/> .
@prefix fabio: <http://purl.org/spar/fabio/> .
@prefix oa: <http://www.w3.org/ns/oa#> .
@prefix dcterms: <http://purl.org/dc/terms/> .
@prefix foaf: <http://xmlns.com/foaf/0.1/> .
@prefix cnt: <http://www.w3.org/2011/content#> .
@prefix c4o: <http://purl.org/spar/c4o/> .
@prefix per: <http://data.semanticweb.org/person/> .
### Defining mention links and their types (direct vs reified)
MiTO lets you connect two resources where one (the _mentioning entity_, e.g., a paper) mentions another (the _mentioned entity_, e.g., a software, dataset, method), optionally qualifying the mention with a _mention type_ (e.g., explicit/implicit).
As with [CiTO](http://purl.org/spar/cito), you can use a direct triple (`mito:mentions`) or a reified mention (`mito:Mention`) to which you can attach further metadata such as the mention type.
:ml-paper-2024 a fabio:JournalArticle ;
dcterms:title "Deep Learning Approaches for Medical Image Segmentation" ;
mito:mentions :tensorflow .
:tensorflow a fabio:ComputerProgram ;
foaf:name "TensorFlow" ;
mito:isMentionedBy :ml-paper-2024 .
:mention-tensorflow a mito:Mention ;
mito:hasMentioningEntity :ml-paper-2024 ;
mito:hasMentionedEntity :tensorflow ;
mito:hasMentionType mito:explicit .
:vision-paper a fabio:JournalArticle ;
dcterms:title "Novel Architectures for Biomedical Image Classification" .
:imagenet a fabio:Dataset ;
dcterms:title "ImageNet Large Scale Visual Recognition Challenge Dataset" .
:vision-paper mito:mentions :imagenet .
:dataset-mention a mito:Mention ;
mito:hasMentioningEntity :vision-paper ;
mito:hasMentionedEntity :imagenet ;
mito:hasMentionType mito:explicit .
:mention-annotation a oa:Annotation ;
oa:motivatedBy oa:commenting ;
oa:hasTarget :dataset-mention ;
oa:hasBody :usage-context .
:usage-context a cnt:ContentAsText ;
cnt:chars "ImageNet is used exclusively for pre-training the backbone network, not for final model evaluation." .
:nlp-paper a fabio:JournalArticle ;
dcterms:title "Contextual Embeddings for Scientific Text Classification" .
:bert-method a fabio:ResearchPaper ;
dcterms:title "Bidirectional Encoder Representations from Transformers" .
:bert-mention a mito:Mention ;
mito:hasMentioningEntity :nlp-paper ;
mito:hasMentionedEntity :bert-method ;
mito:hasMentionType mito:explicit .
:bert-pointer a c4o:InTextReferencePointer ;
c4o:hasContent "[BERT]" .
:pointer-annotation a oa:Annotation ;
oa:hasTarget :bert-pointer ;
oa:hasBody :bert-mention ;
oa:annotatedBy per:research-team .
:nlp-paper mito:mentions :bert-method .
:stats-paper a fabio:JournalArticle ;
dcterms:title "Bayesian Approaches to Uncertainty Quantification in Deep Learning" .
:bayesian-theory a fabio:ResearchPaper ;
dcterms:title "Bayesian Statistical Inference" .
:stats-paper mito:mentions :bayesian-theory .
:implicit-theory-mention a mito:Mention ;
mito:hasMentioningEntity :stats-paper ;
mito:hasMentionedEntity :bayesian-theory ;
mito:hasMentionType mito:implicit .
:implicit-annotation a oa:Annotation ;
oa:motivatedBy oa:commenting ;
oa:hasTarget :implicit-theory-mention ;
oa:hasBody :implicit-explanation .
:implicit-explanation a cnt:ContentAsText ;
cnt:chars "Bayesian theory is applied throughout the methodology but never explicitly referenced by name." .
## Competency Questions
MiTO can be used for answering several questions related to mentions in scholarly resources.
In the following subsections, some of them are introduced together with their respective SPARQL queries.
The prefixes that are used in all the SPARQL queries provided below are defined as follows:
PREFIX mito: <http://purl.org/spar/mito/>
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX foaf: <http://xmlns.com/foaf/0.1/>
PREFIX oa: <http://www.w3.org/ns/oa#>
PREFIX cnt: <http://www.w3.org/2011/content#>
PREFIX c4o: <http://purl.org/spar/c4o/>
### CQ1
Which entities are mentioned by a document, along with their types and titles?
SELECT ?document ?mentionedEntity ?entityType ?entityName
WHERE {
?document mito:mentions ?mentionedEntity .
?mentionedEntity a ?entityType .
OPTIONAL { ?mentionedEntity dcterms:title ?entityName . }
OPTIONAL { ?mentionedEntity foaf:name ?entityName . }
}
### CQ2
What are the mentions, their types, and the entities involved?
SELECT ?mention ?mentioningEntity ?mentionedEntity ?mentionType
WHERE {
?mention a mito:Mention ;
mito:hasMentioningEntity ?mentioningEntity ;
mito:hasMentionedEntity ?mentionedEntity ;
mito:hasMentionType ?mentionType .
}
### CQ3
What textual comments or annotations target a specific mention?
SELECT ?mention ?mentionType ?commentText
WHERE {
?mention a mito:Mention ;
mito:hasMentionType ?mentionType .
?annotation a oa:Annotation ;
oa:hasTarget ?mention ;
oa:hasBody ?body .
?body cnt:chars ?commentText .
}
### CQ4
Which in-text reference pointers are linked to a mention via annotations?
SELECT ?pointer ?pointerContent ?mention ?mentionedEntity ?annotator
WHERE {
?pointer a c4o:InTextReferencePointer ;
c4o:hasContent ?pointerContent .
?annotation a oa:Annotation ;
oa:hasTarget ?pointer ;
oa:hasBody ?mention .
?mention a mito:Mention ;
mito:hasMentionedEntity ?mentionedEntity .
OPTIONAL { ?annotation oa:annotatedBy ?annotator . }
}